Low severity · published May 7, 2020
CVE-2020-11048
In FreeRDP after 1.0 and before 2.0.0, there is an out-of-bounds read
2.2
CVSS
1.8%
EPSS
No
On KEV
Description
In FreeRDP after 1.0 and before 2.0.0, there is an out-of-bounds read. It only allows to abort a session. No data extraction is possible. This has been fixed in 2.0.0.
CVSS vector
CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:N/I:N/A:L
Attack vector
Network
Complexity
High
Privileges
High
User interaction
None
Confidentiality
None
Integrity
None
Availability
Low
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)1.8% · higher than 79% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
DL
Debian Linux · Debian
9.0; 10.0 · source: NVD
FR
Freerdp · Freerdp
1.0.0 before 2.0.0 · source: NVD
UL
Ubuntu Linux · Canonical
16.04; 18.04; 19.10; 20.04 · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2020-11048
CVE.org
https://www.cve.org/CVERecord?id=CVE-2020-11048
Patch
https://github.com/FreeRDP/FreeRDP/commit/9301bfe730c66180263248b74353daa99f5a969b
Exploit
https://github.com/FreeRDP/FreeRDP/issues/6007
Third Party Advisory
https://github.com/FreeRDP/FreeRDP/security/advisories/GHSA-hv8w-f2hx-5gcv
Third Party Advisory
https://lists.debian.org/debian-lts-announce/2020/08/msg00054.html
Mailing List
https://lists.debian.org/debian-lts-announce/2023/10/msg00008.html
Third Party Advisory
https://usn.ubuntu.com/4379-1/
More from Ubuntu Linux
9.8
CVE-2020-11651
SaltStack Salt Authentication Bypass Vulnerability
9.8
CVE-2020-7247
OpenSMTPD Remote Code Execution Vulnerability
9.8
CVE-2019-11043
Underflow in PHP-FPM can lead to RCE
9.8
CVE-2019-16928
Exim Out-of-bounds Write Vulnerability
9.8
CVE-2019-10149
Exim Mail Transfer Agent (MTA) Improper Input Validation
