High severity · published Apr 30, 2020
CVE-2020-11028
In affected versions of WordPress, some private posts, which were previously public, can result in unauthenticated disclosure under a specific set of conditions
7.5
CVSS
2.3%
EPSS
No
On KEV
Description
In affected versions of WordPress, some private posts, which were previously public, can result in unauthenticated disclosure under a specific set of conditions. This has been patched in version 5.4.1, along with all the previously affected versions via a minor release (5.3.3, 5.2.6, 5.1.5, 5.0.9, 4.9.14, 4.8.13, 4.7.17, 4.6.18, 4.5.21, 4.4.22, 4.3.23, 4.2.27, 4.1.30, 4.0.30, 3.9.31, 3.8.33, 3.7.33).
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
None
Confidentiality
High
Integrity
None
Availability
None
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)2.3% · higher than 83% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
WO
WordPress · WordPress
before 5.4.1 · source: NVD
DL
Debian Linux · Debian
9.0; 10.0; 8.0 · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2020-11028
CVE.org
https://www.cve.org/CVERecord?id=CVE-2020-11028
Third Party Advisory
https://github.com/WordPress/wordpress-develop/security/advisories/GHSA-xhx9-759f-6p2w
Mailing List
https://lists.debian.org/debian-lts-announce/2020/05/msg00011.html
Release Notes
https://wordpress.org/support/wordpress-version/version-5-4-1/#security-updates
Third Party Advisory
https://www.debian.org/security/2020/dsa-4677
More from WordPress
9.8
CVE-2026-63030
WordPress < 7.0.2 - REST API batch-route confusion and SQL injection issue leading to Remote Code Execution
9.8
CVE-2020-25213
WordPress File Manager Plugin Remote Code Execution Vulnerability
9.8
CVE-2016-10033
The mailSend function in the isMail transport in PHPMailer before 5.2.18 might allow remote attackers to pass extra parameters to the mail command and consequently execute…
8.1
CVE-2026-87902
WordPress Core Remote File Inclusion Vulnerability
7.5
CVE-2020-11738
WordPress Snap Creek Duplicator Plugin File Download Vulnerability
