Medium severity · published Apr 30, 2020
CVE-2020-11026
In affected versions of WordPress, files with a specially crafted name when uploaded to the Media section can lead to script execution upon accessing the file
5.4
CVSS
2.1%
EPSS
No
On KEV
Description
In affected versions of WordPress, files with a specially crafted name when uploaded to the Media section can lead to script execution upon accessing the file. This requires an authenticated user with privileges to upload files. This has been patched in version 5.4.1, along with all the previously affected versions via a minor release (5.3.3, 5.2.6, 5.1.5, 5.0.9, 4.9.14, 4.8.13, 4.7.17, 4.6.18, 4.5.21, 4.4.22, 4.3.23, 4.2.27, 4.1.30, 4.0.30, 3.9.31, 3.8.33, 3.7.33).
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Attack vector
Network
Complexity
Low
Privileges
Low
User interaction
Required
Confidentiality
Low
Integrity
Low
Availability
None
Scope
Changed
Exploitation
Is it being used?
Exploit prediction (EPSS)2.1% · higher than 82% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
WO
WordPress · WordPress
3.7 before 3.7.33; 3.8 before 3.8.33; 3.9 before 3.9.31; 4.0 before 4.0.30; 4.1 before 4.1.30; 4.2 before 4.2.27; +12 more · source: NVD
DL
Debian Linux · Debian
8.0; 9.0; 10.0 · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2020-11026
CVE.org
https://www.cve.org/CVERecord?id=CVE-2020-11026
Third Party Advisory
https://github.com/WordPress/wordpress-develop/security/advisories/GHSA-3gw2-4656-pfr2
Mailing List
https://lists.debian.org/debian-lts-announce/2020/05/msg00011.html
Release Notes
https://wordpress.org/support/wordpress-version/version-5-4-1/#security-updates
Third Party Advisory
https://www.debian.org/security/2020/dsa-4677
More from WordPress
9.8
CVE-2026-63030
WordPress < 7.0.2 - REST API batch-route confusion and SQL injection issue leading to Remote Code Execution
9.8
CVE-2020-25213
WordPress File Manager Plugin Remote Code Execution Vulnerability
9.8
CVE-2016-10033
The mailSend function in the isMail transport in PHPMailer before 5.2.18 might allow remote attackers to pass extra parameters to the mail command and consequently execute…
8.1
CVE-2026-87902
WordPress Core Remote File Inclusion Vulnerability
7.5
CVE-2020-11738
WordPress Snap Creek Duplicator Plugin File Download Vulnerability
