Medium severity · published May 29, 2020
CVE-2020-11018
In FreeRDP less than or equal to 2.0.0, a possible resource exhaustion vulnerability can be performed
6.5
CVSS
1.9%
EPSS
No
On KEV
Description
In FreeRDP less than or equal to 2.0.0, a possible resource exhaustion vulnerability can be performed. Malicious clients could trigger out of bound reads causing memory allocation with random size. This has been fixed in 2.1.0.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
Attack vector
Network
Complexity
Low
Privileges
Low
User interaction
None
Confidentiality
None
Integrity
None
Availability
High
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)1.9% · higher than 80% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
DL
Debian Linux · Debian
10.0 · source: NVD
FR
Freerdp · Freerdp
through 2.0.0 · source: NVD
LE
Leap · Opensuse
15.1 · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2020-11018
CVE.org
https://www.cve.org/CVERecord?id=CVE-2020-11018
Mailing List
http://lists.opensuse.org/opensuse-security-announce/2020-07/msg00080.html
Third Party Advisory
https://github.com/FreeRDP/FreeRDP/security/advisories/GHSA-8cvc-vcw7-6mfw
Mailing List
https://lists.debian.org/debian-lts-announce/2023/10/msg00008.html
More from Debian Linux
10.0
CVE-2025-32433
Erlang/OTP SSH Vulnerable to Pre-Authentication RCE
10.0
CVE-2025-24201
Apple Multiple Products WebKit Out-of-Bounds Write Vulnerability
10.0
CVE-2021-44228
Apache Log4j2 JNDI features do not protect against attacker controlled LDAP and other JNDI related endpoints
10.0
CVE-2015-3306
ProFTPD Improper Access Control Vulnerability
9.8
CVE-2026-111497
Out-of-Bounds Write in Google Brotli Decoder
