Critical severity · published Mar 2, 2020
CVE-2020-10018
WebKitGTK through 2.26.4 and WPE WebKit through 2.26.4 (which are the versions right before 2.28.0) contains a memory corruption issue (use-after-free) that may lead to arbitrary…
9.8
CVSS
5%
EPSS
No
On KEV
Description
WebKitGTK through 2.26.4 and WPE WebKit through 2.26.4 (which are the versions right before 2.28.0) contains a memory corruption issue (use-after-free) that may lead to arbitrary code execution. This issue has been fixed in 2.28.0 with improved memory handling.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
None
Confidentiality
High
Integrity
High
Availability
High
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)5.0% · higher than 92% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
DL
Debian Linux · Debian
10.0 · source: NVD
FE
Fedora · Fedoraproject
30; 31 · source: NVD
LE
Leap · Opensuse
15.1 · source: NVD
UL
Ubuntu Linux · Canonical
18.04; 19.10 · source: NVD
WE
Webkitgtk · Webkitgtk
before 2.28.0 · source: NVD
WW
Wpe Webkit · Wpewebkit
before 2.28.0 · source: NVD