High severity · published Dec 13, 2022
CVE-2019-25078
A vulnerability classified as problematic was found in pacparser up to 1.3.x
7.8
CVSS
0.4%
EPSS
No
On KEV
Description
A vulnerability classified as problematic was found in pacparser up to 1.3.x. Affected by this vulnerability is the function pacparser_find_proxy of the file src/pacparser.c. The manipulation of the argument url leads to buffer overflow. Attacking locally is a requirement. Upgrading to version 1.4.0 is able to address this issue. The name of the patch is 853e8f45607cb07b877ffd270c63dbcdd5201ad9. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-215443.
CVSS vector
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Attack vector
Local
Complexity
Low
Privileges
Low
User interaction
None
Confidentiality
High
Integrity
High
Availability
High
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)0.4% · higher than 39% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
PA
Pacparser · Pacparser Project
before 1.4.0 · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2019-25078
CVE.org
https://www.cve.org/CVERecord?id=CVE-2019-25078
Patch
https://github.com/manugarg/pacparser/commit/853e8f45607cb07b877ffd270c63dbcdd5201ad9
Exploit
https://github.com/manugarg/pacparser/issues/99
Release Notes
https://github.com/manugarg/pacparser/releases/tag/v1.4.0
Permissions Required
https://vuldb.com/?id.215443
More from Pacparser
6.1
CVE-2023-37360
pacparser_find_proxy in Pacparser before 1.4.2 allows JavaScript injection, and possibly privilege escalation, when the attacker controls the URL (which may be realistic within…
