High severity · published Jan 15, 2020
CVE-2019-15010
Bitbucket Server and Bitbucket Data Center versions starting from version 3.0.0 before version 5.16.11, from version 6.0.0 before 6.0.11, from version 6.1.0 before 6.1.9, from…
8.8
CVSS
2.6%
EPSS
No
On KEV
Description
Bitbucket Server and Bitbucket Data Center versions starting from version 3.0.0 before version 5.16.11, from version 6.0.0 before 6.0.11, from version 6.1.0 before 6.1.9, from version 6.2.0 before 6.2.7, from version 6.3.0 before 6.3.6, from version 6.4.0 before 6.4.4, from version 6.5.0 before 6.5.3, from version 6.6.0 before 6.6.3, from version 6.7.0 before 6.7.3, from version 6.8.0 before 6.8.2, and from version 6.9.0 before 6.9.1 had a Remote Code Execution vulnerability via certain user input fields. A remote attacker with user level permissions can exploit this vulnerability to run arbitrary commands on the victim's systems. Using a specially crafted payload as user input, the attacker can execute arbitrary commands on the victim's Bitbucket Server or Bitbucket Data Center instance.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Attack vector
Network
Complexity
Low
Privileges
Low
User interaction
None
Confidentiality
High
Integrity
High
Availability
High
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)2.6% · higher than 85% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
BI
Bitbucket · Atlassian
3.0.0 before 5.6.11; 6.0.0 before 6.0.11; 6.1.0 before 6.1.9; 6.2.0 before 6.2.7; 6.3.0 before 6.3.6; 6.4.0 before 6.4.4; +5 more · source: NVD
Affected product
BI
Bitbucket
Atlassian
More from Bitbucket
8.8
CVE-2022-36804
Atlassian Bitbucket Server and Data Center Command Injection Vulnerability
7.5
CVE-2026-21589
Atlassian Multiple Products Files or Directories Accessible to External Parties Vulnerability
9.9
CVE-2018-5225
In browser editing in Atlassian Bitbucket Server from version 4.13.0 before 5.4.8 (the fixed version for 4.13.0 through 5.4.7), 5.5.0 before 5.5.8 (the fixed version for 5.5.x),…
9.8
CVE-2022-43781
There is a command injection vulnerability using environment variables in Bitbucket Server and Data Center
9.8
CVE-2022-26136
A vulnerability in multiple Atlassian products allows a remote, unauthenticated attacker to bypass Servlet Filters used by first and third party apps