High severity · published Jul 10, 2019
CVE-2019-12472
An Incorrect Access Control vulnerability was found in Wikimedia MediaWiki 1.18.0 through 1.32.1
7.5
CVSS
1.3%
EPSS
No
On KEV
Description
An Incorrect Access Control vulnerability was found in Wikimedia MediaWiki 1.18.0 through 1.32.1. It is possible to bypass the limits on IP range blocks ($wgBlockCIDRLimit) by using the API. Fixed in 1.32.2, 1.31.2, 1.30.2 and 1.27.6.
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
None
Confidentiality
None
Integrity
High
Availability
None
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)1.3% · higher than 71% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
ME
Mediawiki · Mediawiki
1.18.0 before 1.27.6; 1.30.0 before 1.30.2; 1.31.0 before 1.31.2; 1.32.0 before 1.32.2 · source: NVD
Affected product
ME
Mediawiki
Mediawiki
More from Mediawiki
9.8
CVE-2026-58025
Remote Code Execution via Unsafe Deserialization in LogItem Import
9.8
CVE-2025-67484
Action API xslt option allows JavaScript execution by administrators who are not interface administrators
9.8
CVE-2024-34502
An issue was discovered in WikibaseLexeme in MediaWiki before 1.39.6, 1.40.x before 1.40.2, and 1.41.x before 1.41.1
9.8
CVE-2023-37303
An issue was discovered in the CheckUser extension for MediaWiki through 1.39.3
9.8
CVE-2023-29141
An issue was discovered in MediaWiki before 1.35.10, 1.36.x through 1.38.x before 1.38.6, and 1.39.x before 1.39.3