High severity · published Oct 17, 2019
CVE-2019-11253
Improper input validation in the Kubernetes API server in versions v1.0-1.12 and versions prior to v1.13.12, v1.14.8, v1.15.5, and v1.16.2 allows authorized users to send…
7.5
CVSS
25.9%
EPSS
No
On KEV
Description
Improper input validation in the Kubernetes API server in versions v1.0-1.12 and versions prior to v1.13.12, v1.14.8, v1.15.5, and v1.16.2 allows authorized users to send malicious YAML or JSON payloads, causing the API server to consume excessive CPU or memory, potentially crashing and becoming unavailable. Prior to v1.14.0, default RBAC policy authorized anonymous users to submit requests that could trigger this vulnerability. Clusters upgraded from a version prior to v1.14.0 keep the more permissive policy by default for backwards compatibility.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
None
Confidentiality
None
Integrity
None
Availability
High
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)25.9% · higher than 98% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
KU
Kubernetes · Kubernetes
1.1.0 through 1.12.10; 1.13.0 before 1.13.12; 1.14.0 before 1.14.8; 1.15.0 before 1.15.5; 1.16.0 before 1.16.2 · source: NVD
OC
Openshift Container Platform · Redhat
3.9; 3.10; 3.11 · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2019-11253
CVE.org
https://www.cve.org/CVERecord?id=CVE-2019-11253
Third Party Advisory
https://access.redhat.com/errata/RHSA-2019:3239
Third Party Advisory
https://access.redhat.com/errata/RHSA-2019:3811
Third Party Advisory
https://access.redhat.com/errata/RHSA-2019:3905
Exploit
https://github.com/kubernetes/kubernetes/issues/83253
Permissions Required
https://groups.google.com/forum/#%21topic/kubernetes-security-announce/jk8polzSUxs
Third Party Advisory
https://security.netapp.com/advisory/ntap-20191031-0006/
More from Kubernetes
9.8
CVE-2018-1002105
In all Kubernetes versions prior to v1.10.11, v1.11.5, and v1.12.3, incorrect handling of error responses to proxied upgrade requests in the kube-apiserver allowed specially…
9.8
CVE-2018-1002101
In Kubernetes versions 1.9.0-1.9.9, 1.10.0-1.10.5, and 1.11.0-1.11.1, user input was handled insecurely while setting up volume mounts on Windows nodes, which could lead to…
9.8
CVE-2017-1000056
Kubernetes version 1.5.0-1.5.4 is vulnerable to a privilege escalation in the PodSecurityPolicy admission plugin resulting in the ability to make use of any existing…
9.8
CVE-2016-1906
Openshift allows remote attackers to gain privileges by updating a build configuration that was created with an allowed type to a type that is not allowed
9.6
CVE-2017-1002101
In Kubernetes versions 1.3.x, 1.4.x, 1.5.x, 1.6.x and prior to versions 1.7.14, 1.8.9 and 1.9.4 containers using subpath volume mounts with any volume type (including…
