Critical severity · published Jul 15, 2019
CVE-2019-1010297
Linaro/OP-TEE OP-TEE 3.3.0 and earlier is affected by: Buffer Overflow
9.8
CVSS
2.7%
EPSS
No
On KEV
Description
Linaro/OP-TEE OP-TEE 3.3.0 and earlier is affected by: Buffer Overflow. The impact is: Execution of code in TEE core (kernel) context. The component is: optee_os. The fixed version is: 3.4.0 and later.
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
None
Confidentiality
High
Integrity
High
Availability
High
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)2.7% · higher than 86% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
OP
Op-tee · Trustedfirmware
through 3.3.0 · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2019-1010297
CVE.org
https://www.cve.org/CVERecord?id=CVE-2019-1010297
Patch
https://github.com/OP-TEE/optee_os/commit/a637243270fc1faae16de059091795c32d86e65e
More from Op-tee
9.8
CVE-2019-1010292
Linaro/OP-TEE OP-TEE Prior to version v3.4.0 is affected by: Boundary checks
9.8
CVE-2019-1010298
Linaro/OP-TEE OP-TEE 3.3.0 and earlier is affected by: Buffer Overflow
9.8
CVE-2019-1010296
Linaro/OP-TEE OP-TEE 3.3.0 and earlier is affected by: Buffer Overflow
9.8
CVE-2019-1010295
Linaro/OP-TEE OP-TEE 3.3.0 and earlier is affected by: Buffer Overflow
9.8
CVE-2019-1010293
Linaro/OP-TEE OP-TEE 3.3.0 and earlier is affected by: Boundary crossing
