Medium severity · published Jul 17, 2019
CVE-2019-1010266
lodash prior to 4.17.11 is affected by: CWE-400: Uncontrolled Resource Consumption
6.5
CVSS
3%
EPSS
No
On KEV
Description
lodash prior to 4.17.11 is affected by: CWE-400: Uncontrolled Resource Consumption. The impact is: Denial of service. The component is: Date handler. The attack vector is: Attacker provides very long strings, which the library attempts to match using a regular expression. The fixed version is: 4.17.11.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
Attack vector
Network
Complexity
Low
Privileges
Low
User interaction
None
Confidentiality
None
Integrity
None
Availability
High
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)3.0% · higher than 87% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
LO
Lodash · Lodash
before 4.17.11 · source: NVD
Affected product
LO
Lodash
Lodash
More from Lodash
9.8
CVE-2026-4800
lodash vulnerable to Code Injection via `_.template` imports key names
9.1
CVE-2019-10744
Versions of lodash lower than 4.17.12 are vulnerable to Prototype Pollution
7.4
CVE-2020-8203
Prototype pollution attack when using _.zipObjectDeep in lodash before 4.17.20
7.2
CVE-2021-23337
Command Injection
6.5
CVE-2018-3721
lodash node module before 4.17.5 suffers from a Modification of Assumed-Immutable Data (MAID) vulnerability via defaultsDeep, merge, and mergeWith functions, which allows a…