Critical severity · published Jul 25, 2019
CVE-2019-1010161
perl-CRYPT-JWT 0.022 and earlier is affected by: Incorrect Access Control
9.8
CVSS
1.1%
EPSS
No
On KEV
Description
perl-CRYPT-JWT 0.022 and earlier is affected by: Incorrect Access Control. The impact is: bypass authentication. The component is: JWT.pm for JWT security token, line 614 in _decode_jws(). The attack vector is: network connectivity(crafting user-controlled input to bypass authentication). The fixed version is: 0.023.
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
None
Confidentiality
High
Integrity
High
Availability
High
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)1.1% · higher than 66% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
PE
Perl-crypt-jwt · Perl-crypt-jwt Project
through 0.022 · source: NVD
Affected product
PE
Perl-crypt-jwt
Perl-crypt-jwt Project
More from Perl-crypt-jwt
9.8
CVE-2019-1010263
Perl Crypt::JWT prior to 0.023 is affected by: Incorrect Access Control