High severity · published Oct 22, 2019
CVE-2019-10079
Apache Traffic Server is vulnerable to HTTP/2 setting flood attacks
7.5
CVSS
4.6%
EPSS
No
On KEV
Description
Apache Traffic Server is vulnerable to HTTP/2 setting flood attacks. Earlier versions of Apache Traffic Server didn't limit the number of setting frames sent from the client using the HTTP/2 protocol. Users should upgrade to Apache Traffic Server 7.1.7, 8.0.4, or later versions.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
None
Confidentiality
None
Integrity
None
Availability
High
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)4.6% · higher than 92% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
TS
Traffic Server · Apache
before 7.1.7; 8.0.0 before 8.0.4 · source: NVD
Affected product
TS
Traffic Server
Apache
More from Traffic Server
10.0
CVE-2026-58162
Apache Traffic Server: Certifier plugin trusts client SNI when generating certificates
10.0
CVE-2026-58150
Apache Traffic Server: HTTP/2 requests with Transfer-Encoding are not rejected, allowing request smuggling
10.0
CVE-2026-57834
Apache Traffic Server: Malformed chunked message body allows request smuggling
9.8
CVE-2026-58185
Apache Traffic Server: Use-after-free in the intercept plugin
9.8
CVE-2026-58179
Apache Traffic Server: regex_remap plugin overflows the stack from attacker input