High severity · published Apr 10, 2019
CVE-2019-1003049
Users who cached their CLI authentication before Jenkins was updated to 2.150.2 and newer, or 2.160 and newer, would remain authenticated in Jenkins 2.171 and earlier and Jenkins…
8.1
CVSS
2.1%
EPSS
No
On KEV
Description
Users who cached their CLI authentication before Jenkins was updated to 2.150.2 and newer, or 2.160 and newer, would remain authenticated in Jenkins 2.171 and earlier and Jenkins LTS 2.164.1 and earlier, because the fix for CVE-2019-1003004 in these releases did not reject existing remoting-based CLI authentication caches.
CVSS vector
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Attack vector
Network
Complexity
High
Privileges
None
User interaction
None
Confidentiality
High
Integrity
High
Availability
High
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)2.1% · higher than 82% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
JE
Jenkins · Jenkins
through 2.164.1; through 2.171 · source: NVD
CC
Communications Cloud Native Core Automated Test Suite · Oracle
1.9.0 · source: NVD
OC
Openshift Container Platform · Redhat
3.11 · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2019-1003049
CVE.org
https://www.cve.org/CVERecord?id=CVE-2019-1003049
Broken Link
http://www.securityfocus.com/bid/107901
Third Party Advisory
https://access.redhat.com/errata/RHBA-2019:1605
Vendor Advisory
https://jenkins.io/security/advisory/2019-04-10/#SECURITY-1289
Patch
https://www.oracle.com/security-alerts/cpuapr2022.html
More from Jenkins
9.9
CVE-2019-1003029
Jenkins Script Security Plugin Sandbox Bypass Vulnerability
9.9
CVE-2019-1003030
Jenkins Matrix Project Plugin Remote Code Execution Vulnerability
9.8
CVE-2024-23897
Jenkins Command Line Interface (CLI) Path Traversal Vulnerability
9.8
CVE-2018-1000861
A code execution vulnerability exists in the Stapler web framework used by Jenkins 2.153 and earlier, LTS 2.138.3 and earlier in…
9.8
CVE-2017-1000353
Jenkins versions 2.56 and earlier as well as 2.46.1 LTS and earlier are vulnerable to an unauthenticated remote code execution
