Medium severity · published Jun 11, 2019
CVE-2019-0197
A vulnerability was found in Apache HTTP Server 2.4.34 to 2.4.38
4.2
CVSS
8.6%
EPSS
No
On KEV
Description
A vulnerability was found in Apache HTTP Server 2.4.34 to 2.4.38. When HTTP/2 was enabled for a http: host or H2Upgrade was enabled for h2 on a https: host, an Upgrade request from http/1.1 to http/2 that was not the first request on a connection could lead to a misconfiguration and crash. Server that never enabled the h2 protocol or that only enabled it for https: and did not set "H2Upgrade on" are unaffected by this issue.
CVSS vector
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:L/A:L
Attack vector
Network
Complexity
High
Privileges
Low
User interaction
None
Confidentiality
None
Integrity
Low
Availability
Low
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)8.6% · higher than 95% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
HS
HTTP Server · Apache
2.4.34 through 2.4.38 · source: NVD
CS
Communications Session Report Manager · Oracle
8.0.0; 8.1.0; 8.1.1; 8.2.0 · source: NVD
CS
Communications Session Route Manager · Oracle
8.0.0; 8.1.0; 8.1.1; 8.2.0 · source: NVD
EM
Enterprise Manager Ops Center · Oracle
12.3.3; 12.4.0 · source: NVD
FE
Fedora · Fedoraproject
30 · source: NVD
IE
Instantis Enterprisetrack · Oracle
17.1; 17.2; 17.3 · source: NVD
JC
Jboss Core Services · Redhat
1.0 · source: NVD
LE
Leap · Opensuse
15.0; 42.3 · source: NVD
RX
Retail Xstore Point OF Service · Oracle
7.0; 7.1 · source: NVD
UL
Ubuntu Linux · Canonical
16.04; 18.04; 19.04 · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2019-0197
CVE.org
https://www.cve.org/CVERecord?id=CVE-2019-0197
Mailing List
http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00051.html
Mailing List
http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00061.html
Mailing List
http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00084.html
Mailing List
http://www.openwall.com/lists/oss-security/2019/04/02/2
Third Party Advisory
http://www.securityfocus.com/bid/107665
Third Party Advisory
https://access.redhat.com/errata/RHSA-2019:3932
More from HTTP Server
9.8
CVE-2021-42013
Path Traversal and Remote Code Execution in Apache HTTP Server 2.4.49 and 2.4.50 (incomplete fix of CVE-2021-41773)
9.8
CVE-2021-41773
Path traversal and file disclosure vulnerability in Apache HTTP Server 2.4.49
9.1
CVE-2024-38475
Apache HTTP Server weakness in mod_rewrite when first segment of substitution matches filesystem path.
9.0
CVE-2021-40438
mod_proxy SSRF
7.8
CVE-2019-0211
Apache HTTP Server Privilege Escalation Vulnerability
