Medium severity · published Mar 4, 2018
CVE-2018-7651
index.js in the ssri module before 5.2.2 for Node.js is prone to a regular expression denial of service vulnerability in strict mode functionality via a long base64 hash string
5.9
CVSS
1.7%
EPSS
No
On KEV
Description
index.js in the ssri module before 5.2.2 for Node.js is prone to a regular expression denial of service vulnerability in strict mode functionality via a long base64 hash string.
CVSS vector
CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
Attack vector
Network
Complexity
High
Privileges
None
User interaction
None
Confidentiality
None
Integrity
None
Availability
High
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)1.7% · higher than 77% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
SS
Ssri · Ssri Project
before 5.2.2 · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2018-7651
CVE.org
https://www.cve.org/CVERecord?id=CVE-2018-7651
Patch
https://github.com/zkat/ssri/commit/d0ebcdc22cb5c8f47f89716d08b3518b2485d65d
Third Party Advisory
https://github.com/zkat/ssri/issues/10
Third Party Advisory
https://nodesecurity.io/advisories/565
More from Ssri
7.5
CVE-2021-27290
ssri 5.2.2-8.0.0, fixed in 8.0.1, processes SRIs using a regular expression which is vulnerable to a denial of service
