Medium severity · published Mar 11, 2022
CVE-2018-25031
Swagger UI 4.1.2 and earlier could allow a remote attacker to conduct spoofing attacks
4.3
CVSS
42.3%
EPSS
No
On KEV
Description
Swagger UI 4.1.2 and earlier could allow a remote attacker to conduct spoofing attacks. By persuading a victim to open a crafted URL, an attacker could exploit this vulnerability to display remote OpenAPI definitions. Note: This was originally claimed to be resolved in 4.1.3. However, third parties have indicated this is not resolved in 4.1.3 and even occurs in that version and possibly others.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:N
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
Required
Confidentiality
Low
Integrity
None
Availability
None
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)42.3% · higher than 99% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
SU
Swagger UI · Smartbear
before 4.1.3 · source: NVD
Affected product
SU
Swagger UI
Smartbear
More from Swagger UI
9.8
CVE-2019-17495
A Cascading Style Sheets (CSS) injection vulnerability in Swagger UI before 3.23.11 allows attackers to use the Relative Path Overwrite (RPO) technique to perform CSS-based input…
6.1
CVE-2016-1000229
swagger-ui has XSS in key names
6.1
CVE-2016-5682
Swagger-UI before 2.2.1 has XSS via the Default field in the Definitions section
5.3
CVE-2024-22207
fastify-swagger-ui is a Fastify plugin for serving Swagger UI