Medium severity · published Sep 11, 2020
CVE-2018-19946
The vulnerability have been reported to affect earlier versions of Helpdesk
5.9
CVSS
0.3%
EPSS
No
On KEV
Description
The vulnerability have been reported to affect earlier versions of Helpdesk. If exploited, this improper certificate validation vulnerability could allow an attacker to spoof a trusted entity by interfering in the communication path between the host and client. QNAP has already fixed the issue in Helpdesk 3.0.3 and later.
CVSS vector
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N
Attack vector
Network
Complexity
High
Privileges
None
User interaction
None
Confidentiality
None
Integrity
High
Availability
None
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)0.3% · higher than 24% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
HE
Helpdesk · Qnap
before 3.0.3 · source: NVD
Affected product
HE
Helpdesk
Qnap
More from Helpdesk
9.8
CVE-2020-2506
improper access control vulnerability in Helpdesk
9.8
CVE-2020-2507
The vulnerability have been reported to affect earlier versions of QTS
9.8
CVE-2018-0714
Command injection vulnerability in Helpdesk versions 1.1.21 and earlier in QNAP QTS 4.2.6 build 20180531, QTS 4.3.3 build 20180528, QTS 4.3.4 build 20180528 and their earlier…
8.8
CVE-2024-50394
An improper certificate validation vulnerability has been reported to affect Helpdesk
8.8
CVE-2021-28814
An improper access control vulnerability has been reported to affect QNAP NAS