High severity · published Nov 26, 2018
CVE-2018-16854
A flaw was found in moodle versions 3.5 to 3.5.2, 3.4 to 3.4.5, 3.3 to 3.3.8, 3.1 to 3.1.14 and earlier
8.8
CVSS
2.3%
EPSS
No
On KEV
Description
A flaw was found in moodle versions 3.5 to 3.5.2, 3.4 to 3.4.5, 3.3 to 3.3.8, 3.1 to 3.1.14 and earlier. The login form is not protected by a token to prevent login cross-site request forgery. Fixed versions include 3.6, 3.5.3, 3.4.6, 3.3.9 and 3.1.15.
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
Required
Confidentiality
High
Integrity
High
Availability
High
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)2.3% · higher than 83% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
MO
Moodle · Moodle
through 3.0.10; 3.1.0 before 3.1.15; 3.3.0 before 3.3.9; 3.4.0 before 3.4.6; 3.5.0 before 3.5.3 · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2018-16854
CVE.org
https://www.cve.org/CVERecord?id=CVE-2018-16854
Patch
http://git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-63183
Third Party Advisory
http://www.securityfocus.com/bid/106017
Third Party Advisory
http://www.securitytracker.com/id/1042154
Issue Tracking
https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-16854
Vendor Advisory
https://moodle.org/mod/forum/discuss.php?d=378731
More from Moodle
10.0
CVE-2019-3809
A flaw was found in Moodle versions 3.1 to 3.1.15 and earlier unsupported versions
9.8
CVE-2025-67856
A flaw was found in Moodle
9.8
CVE-2025-26533
An SQL injection risk was identified in the module list filter within course search
9.8
CVE-2024-33999
The referrer URL used by MFA required additional sanitizing, rather than being used directly
9.8
CVE-2023-5550
In a shared hosting environment that has been misconfigured to allow access to other users' content, a Moodle user who also has direct access to the web server outside of the…
