High severity · published Apr 25, 2018
CVE-2018-1335
From Apache Tika versions 1.7 to 1.17, clients could send carefully crafted headers to tika-server that could be used to inject commands into the command line of the server…
8.1
CVSS
93.6%
EPSS
No
On KEV
Description
From Apache Tika versions 1.7 to 1.17, clients could send carefully crafted headers to tika-server that could be used to inject commands into the command line of the server running tika-server. This vulnerability only affects those running tika-server on a server that is open to untrusted clients. The mitigation is to upgrade to Tika 1.18.
CVSS vector
CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Attack vector
Network
Complexity
High
Privileges
None
User interaction
None
Confidentiality
High
Integrity
High
Availability
High
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)93.6% · higher than 100% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
TI
Tika · Apache
before 1.18 · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2018-1335
CVE.org
https://www.cve.org/CVERecord?id=CVE-2018-1335
packetstormsecurity.com
http://packetstormsecurity.com/files/153864/Apache-Tika-1.17-Header-Command-Injection.html
Third Party Advisory
http://www.securityfocus.com/bid/104001
access.redhat.com
https://access.redhat.com/errata/RHSA-2019:3140
lists.apache.org
https://lists.apache.org/thread.html/b3ed4432380af767effd4c6f27665cc7b2686acccbefeb9f55851dca%40%3Cdev.tika.apache.org%3E
Exploit
https://www.exploit-db.com/exploits/46540/
More from Tika
9.8
CVE-2026-66756
Apache Tika: unpack endpoint in tika-server allows configuration with unsecureFeatures=false
9.8
CVE-2025-66516
Apache Tika core, Apache Tika parsers, Apache Tika PDF parser module: Update to CVE-2025-54988 to expand scope of artifacts affected
9.8
CVE-2016-6809
Apache Tika before 1.14 allows Java code execution for serialized objects embedded in MATLAB files
8.8
CVE-2019-10088
A carefully crafted or corrupt zip file can cause an OOM in Apache Tika's RecursiveParserWrapper in versions 1.7-1.21
8.4
CVE-2025-54988
Critical XXE in Apache Tika (tika-parser-pdf-module) in Apache Tika 1.13 through and including 3.2.1 on all platforms allows an attacker to carry out XML External Entity injection…
