High severity · published Oct 8, 2018
CVE-2018-1000807
Python Cryptographic Authority pyopenssl version prior to version 17.5.0 contains a CWE-416: Use After Free vulnerability in X509 object handling that can result in Use after free…
8.1
CVSS
4.1%
EPSS
No
On KEV
Description
Python Cryptographic Authority pyopenssl version prior to version 17.5.0 contains a CWE-416: Use After Free vulnerability in X509 object handling that can result in Use after free can lead to possible denial of service or remote code execution.. This attack appear to be exploitable via Depends on the calling application and if it retains a reference to the memory.. This vulnerability appears to have been fixed in 17.5.0.
CVSS vector
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Attack vector
Network
Complexity
High
Privileges
None
User interaction
None
Confidentiality
High
Integrity
High
Availability
High
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)4.1% · higher than 91% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
EL
Enterprise Linux Desktop · Redhat
7.0 · source: NVD
EL
Enterprise Linux Server · Redhat
7.0 · source: NVD
EL
Enterprise Linux Workstation · Redhat
7.0 · source: NVD
OP
Openstack · Redhat
13 · source: NVD
PY
Pyopenssl · Pyopenssl
before 17.5.0 · source: NVD
UL
Ubuntu Linux · Canonical
16.04 · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2018-1000807
CVE.org
https://www.cve.org/CVERecord?id=CVE-2018-1000807
Mailing List
http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00014.html
Third Party Advisory
https://access.redhat.com/errata/RHSA-2019:0085
github.com
https://github.com/pyca/pyopenssl/commit/e73818600065821d588af475b024f4eb518c3509
Patch
https://github.com/pyca/pyopenssl/pull/723
Third Party Advisory
https://usn.ubuntu.com/3813-1/
More from Ubuntu Linux
9.8
CVE-2020-11651
SaltStack Salt Authentication Bypass Vulnerability
9.8
CVE-2020-7247
OpenSMTPD Remote Code Execution Vulnerability
9.8
CVE-2019-11043
Underflow in PHP-FPM can lead to RCE
9.8
CVE-2019-16928
Exim Out-of-bounds Write Vulnerability
9.8
CVE-2019-10149
Exim Mail Transfer Agent (MTA) Improper Input Validation
