High severity · published May 18, 2018
CVE-2018-1000400
Kubernetes CRI-O version prior to 1.9 contains a Privilege Context Switching Error (CWE-270) vulnerability in the handling of ambient capabilities that can result in containers…
8.8
CVSS
2%
EPSS
No
On KEV
Description
Kubernetes CRI-O version prior to 1.9 contains a Privilege Context Switching Error (CWE-270) vulnerability in the handling of ambient capabilities that can result in containers running with elevated privileges, allowing users abilities they should not have. This attack appears to be exploitable via container execution. This vulnerability appears to have been fixed in 1.9.
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Attack vector
Network
Complexity
Low
Privileges
Low
User interaction
None
Confidentiality
High
Integrity
High
Availability
High
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)2.0% · higher than 80% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
CR
Cri-o · Kubernetes
before 1.9.0 · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2018-1000400
CVE.org
https://www.cve.org/CVERecord?id=CVE-2018-1000400
Third Party Advisory
http://www.securityfocus.com/bid/104262
Patch
https://github.com/kubernetes-incubator/cri-o/pull/1558/files
More from Cri-o
8.8
CVE-2022-0811
A flaw was found in CRI-O in the way it set kernel options for a pod
8.1
CVE-2024-5154
A flaw was found in cri-o
7.8
CVE-2022-4318
A vulnerability was found in cri-o
7.5
CVE-2022-1708
A vulnerability was found in CRI-O that causes memory or disk space exhaustion on the node for anyone with access to the Kube API
7.1
CVE-2022-2995
Incorrect handling of the supplementary groups in the CRI-O container engine might lead to sensitive information disclosure or possible data modification if an attacker has direct…
