Medium severity · published Mar 13, 2018
CVE-2018-1000077
RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, Ruby 2.5 series: 2.5.0 and earlier, prior to trunk…
5.3
CVSS
3.6%
EPSS
No
On KEV
Description
RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, Ruby 2.5 series: 2.5.0 and earlier, prior to trunk revision 62422 contains a Improper Input Validation vulnerability in ruby gems specification homepage attribute that can result in a malicious gem could set an invalid homepage URL. This vulnerability appears to have been fixed in 2.7.6.
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
None
Confidentiality
None
Integrity
Low
Availability
None
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)3.6% · higher than 89% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
DL
Debian Linux · Debian
7.0 · source: NVD
RU
Rubygems · Rubygems
through 2.2.9; through 2.3.6; through 2.4.3; through 2.5.0 · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2018-1000077
CVE.org
https://www.cve.org/CVERecord?id=CVE-2018-1000077
Vendor Advisory
http://blog.rubygems.org/2018/02/15/2.7.6-released.html
lists.opensuse.org
http://lists.opensuse.org/opensuse-security-announce/2019-07/msg00036.html
access.redhat.com
https://access.redhat.com/errata/RHSA-2018:3729
access.redhat.com
https://access.redhat.com/errata/RHSA-2018:3730
access.redhat.com
https://access.redhat.com/errata/RHSA-2018:3731
access.redhat.com
https://access.redhat.com/errata/RHSA-2019:2028
More from Debian Linux
10.0
CVE-2025-32433
Erlang/OTP SSH Vulnerable to Pre-Authentication RCE
10.0
CVE-2025-24201
Apple Multiple Products WebKit Out-of-Bounds Write Vulnerability
10.0
CVE-2021-44228
Apache Log4j2 JNDI features do not protect against attacker controlled LDAP and other JNDI related endpoints
10.0
CVE-2015-3306
ProFTPD Improper Access Control Vulnerability
9.8
CVE-2026-111497
Out-of-Bounds Write in Google Brotli Decoder
