High severity · published Mar 13, 2018
CVE-2018-1000073
RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, Ruby 2.5 series: 2.5.0 and earlier, prior to trunk…
7.5
CVSS
4.9%
EPSS
No
On KEV
Description
RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, Ruby 2.5 series: 2.5.0 and earlier, prior to trunk revision 62422 contains a Directory Traversal vulnerability in install_location function of package.rb that can result in path traversal when writing to a symlinked basedir outside of the root. This vulnerability appears to have been fixed in 2.7.6.
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
None
Confidentiality
High
Integrity
None
Availability
None
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)4.9% · higher than 92% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
RU
Rubygems · Rubygems
through 2.2.9; through 2.3.6; through 2.4.3; through 2.5.0 · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2018-1000073
CVE.org
https://www.cve.org/CVERecord?id=CVE-2018-1000073
Vendor Advisory
http://blog.rubygems.org/2018/02/15/2.7.6-released.html
lists.opensuse.org
http://lists.opensuse.org/opensuse-security-announce/2019-07/msg00036.html
access.redhat.com
https://access.redhat.com/errata/RHSA-2018:3729
access.redhat.com
https://access.redhat.com/errata/RHSA-2018:3730
access.redhat.com
https://access.redhat.com/errata/RHSA-2018:3731
access.redhat.com
https://access.redhat.com/errata/RHSA-2019:2028
More from Rubygems
9.8
CVE-2018-1000076
RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, Ruby 2.5 series: 2.5.0 and earlier, prior to trunk…
9.8
CVE-2017-0903
RubyGems versions between 2.0.0 and 2.6.13 are vulnerable to a possible remote code execution vulnerability
9.8
CVE-2017-0899
RubyGems version 2.6.12 and earlier is vulnerable to maliciously crafted gem specifications that include terminal escape characters
8.8
CVE-2022-36073
RubyGems.org is the Ruby community gem host
8.8
CVE-2019-8324
An issue was discovered in RubyGems 2.6 and later through 3.0.2
