High severity · published Feb 9, 2018
CVE-2018-1000024
The Squid Software Foundation Squid HTTP Caching Proxy version 3.0 to 3.5.27, 4.0 to 4.0.22 contains a Incorrect Pointer Handling vulnerability in ESI Response Processing that can…
7.5
CVSS
7.9%
EPSS
No
On KEV
Description
The Squid Software Foundation Squid HTTP Caching Proxy version 3.0 to 3.5.27, 4.0 to 4.0.22 contains a Incorrect Pointer Handling vulnerability in ESI Response Processing that can result in Denial of Service for all clients using the proxy.. This attack appear to be exploitable via Remote server delivers an HTTP response payload containing valid but unusual ESI syntax.. This vulnerability appears to have been fixed in 4.0.23 and later.
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
None
Confidentiality
None
Integrity
None
Availability
High
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)7.9% · higher than 95% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
DL
Debian Linux · Debian
7.0; 8.0; 9.0 · source: NVD
SQ
Squid · Squid-cache
3.0 through 3.5.27; 4.0 through 4.0.22 · source: NVD
UL
Ubuntu Linux · Canonical
14.04; 16.04; 17.10 · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2018-1000024
CVE.org
https://www.cve.org/CVERecord?id=CVE-2018-1000024
Patch
http://www.squid-cache.org/Advisories/SQUID-2018_1.txt
Release Notes
http://www.squid-cache.org/Versions/
Mailing List
https://lists.debian.org/debian-lts-announce/2018/02/msg00001.html
Third Party Advisory
https://usn.ubuntu.com/3557-1/
usn.ubuntu.com
https://usn.ubuntu.com/4059-2/
Third Party Advisory
https://www.debian.org/security/2018/dsa-4122
More from Ubuntu Linux
9.8
CVE-2020-11651
SaltStack Salt Authentication Bypass Vulnerability
9.8
CVE-2020-7247
OpenSMTPD Remote Code Execution Vulnerability
9.8
CVE-2019-11043
Underflow in PHP-FPM can lead to RCE
9.8
CVE-2019-16928
Exim Out-of-bounds Write Vulnerability
9.8
CVE-2019-10149
Exim Mail Transfer Agent (MTA) Improper Input Validation
