Medium severity · published Mar 1, 2018
CVE-2017-6929
A jQuery cross site scripting vulnerability is present when making Ajax requests to untrusted domains
6.1
CVSS
1.2%
EPSS
No
On KEV
Description
A jQuery cross site scripting vulnerability is present when making Ajax requests to untrusted domains. This vulnerability is mitigated by the fact that it requires contributed or custom modules in order to exploit. For Drupal 8, this vulnerability was already fixed in Drupal 8.4.0 in the Drupal core upgrade to jQuery 3. For Drupal 7, it is fixed in the current release (Drupal 7.57) for jQuery 1.4.4 (the version that ships with Drupal 7 core) as well as for other newer versions of jQuery that might be used on the site, for example using the jQuery Update module.
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
Required
Confidentiality
Low
Integrity
Low
Availability
None
Scope
Changed
Exploitation
Is it being used?
Exploit prediction (EPSS)1.2% · higher than 68% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
DR
Drupal · Drupal
7.0 before 7.57; 8.0.0 before 8.4.0 · source: NVD
DL
Debian Linux · Debian
7.0; 8.0; 9.0 · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2017-6929
CVE.org
https://www.cve.org/CVERecord?id=CVE-2017-6929
Issue Tracking
https://lists.debian.org/debian-lts-announce/2018/02/msg00030.html
Third Party Advisory
https://www.debian.org/security/2018/dsa-4123
Mitigation
https://www.drupal.org/sa-core-2018-001
More from Drupal
9.8
CVE-2026-9082
Drupal core - Highly critical - SQL injection - SA-CORE-2026-004
9.8
CVE-2018-7602
Drupal core - Highly critical - Remote Code Execution - SA-CORE-2018-004
9.8
CVE-2018-7600
Drupal Core Remote Code Execution Vulnerability
8.8
CVE-2020-13671
Drupal core Un-restricted Upload of File
8.1
CVE-2019-6340
Drupal core - Highly critical - Remote Code Execution
