Medium severity · published Feb 5, 2023
CVE-2017-20175
A vulnerability classified as problematic has been found in DaSchTour matomo-mediawiki-extension up to 2.4.2 on MediaWiki
6.1
CVSS
0.6%
EPSS
No
On KEV
Description
A vulnerability classified as problematic has been found in DaSchTour matomo-mediawiki-extension up to 2.4.2 on MediaWiki. This affects an unknown part of the file Piwik.hooks.php of the component Username Handler. The manipulation leads to cross site scripting. It is possible to initiate the attack remotely. The complexity of an attack is rather high. The exploitability is told to be difficult. The exploit has been disclosed to the public and may be used. Upgrading to version 2.4.3 is able to address this issue. The patch is named 681324e4f518a8af4bd1f93867074c728eb9923d. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-220203.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
Required
Confidentiality
Low
Integrity
Low
Availability
None
Scope
Changed
Exploitation
Is it being used?
Exploit prediction (EPSS)0.6% · higher than 49% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
MA
Matomo · Mediawiki
2.4.0 before 2.4.3 · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2017-20175
CVE.org
https://www.cve.org/CVERecord?id=CVE-2017-20175
Patch
https://github.com/DaSchTour/matomo-mediawiki-extension/commit/681324e4f518a8af4bd1f93867074c728eb9923d
Exploit
https://github.com/DaSchTour/matomo-mediawiki-extension/pull/17
Release Notes
https://github.com/DaSchTour/matomo-mediawiki-extension/releases/tag/v2.4.3
Permissions Required
https://vuldb.com/?ctiid.220203
Third Party Advisory
https://vuldb.com/?id.220203
