Critical severity · published Sep 5, 2018
CVE-2016-1000030
Pidgin version <2.11.0 contains a vulnerability in X.509 Certificates imports specifically due to improper check of return values from gnutls_x509_crt_init() and…
9.8
CVSS
1.8%
EPSS
No
On KEV
Description
Pidgin version <2.11.0 contains a vulnerability in X.509 Certificates imports specifically due to improper check of return values from gnutls_x509_crt_init() and gnutls_x509_crt_import() that can result in code execution. This attack appear to be exploitable via custom X.509 certificate from another client. This vulnerability appears to have been fixed in 2.11.0.
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
None
Confidentiality
High
Integrity
High
Availability
High
Scope
Unchanged
Exploitation
Is it being used?
Exploit prediction (EPSS)1.8% · higher than 79% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
PI
Pidgin · Pidgin
before 2.11.0 · source: NVD
Affected product
PI
Pidgin
Pidgin
More from Pidgin
9.8
CVE-2017-2640
An out-of-bounds write flaw was found in the way Pidgin before 2.12.0 processed XML content
8.1
CVE-2016-2378
A buffer overflow vulnerability exists in the handling of the MXIT protocol Pidgin
8.1
CVE-2016-2377
A buffer overflow vulnerability exists in the handling of the MXIT protocol in Pidgin
8.1
CVE-2016-2376
A buffer overflow vulnerability exists in the handling of the MXIT protocol in Pidgin
8.1
CVE-2016-2374
An exploitable memory corruption vulnerability exists in the handling of the MXIT protocol in Pidgin