Medium severity · published Mar 6, 2023
CVE-2015-10094
A vulnerability was found in Fastly Plugin up to 0.97 on WordPress
6.1
CVSS
0.5%
EPSS
No
On KEV
Description
A vulnerability was found in Fastly Plugin up to 0.97 on WordPress. It has been rated as problematic. Affected by this issue is the function post of the file lib/api.php. The manipulation of the argument url leads to cross site scripting. The attack may be launched remotely. Upgrading to version 0.98 is able to address this issue. The patch is identified as d7fe42538f4d4af500e3af9678b6b06fba731656. It is recommended to upgrade the affected component. VDB-222326 is the identifier assigned to this vulnerability.
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Attack vector
Network
Complexity
Low
Privileges
None
User interaction
Required
Confidentiality
Low
Integrity
Low
Availability
None
Scope
Changed
Exploitation
Is it being used?
Exploit prediction (EPSS)0.5% · higher than 46% of CVEs
Exploited in the wildNo evidence yet
CISA KEVNot listed
Ransomware campaign useNot known
Affected products
Which versions
FA
Fastly · Fastly
before 0.98 · source: NVD
References
NVD
https://nvd.nist.gov/vuln/detail/CVE-2015-10094
CVE.org
https://www.cve.org/CVERecord?id=CVE-2015-10094
Patch
https://github.com/wp-plugins/fastly/commit/d7fe42538f4d4af500e3af9678b6b06fba731656
Release Notes
https://github.com/wp-plugins/fastly/releases/tag/0.98
Permissions Required
https://vuldb.com/?ctiid.222326
Third Party Advisory
https://vuldb.com/?id.222326
More from Fastly
6.5
CVE-2017-13761
The Fastly CDN module before 1.2.26 for Magento2, when used with a third-party authentication plugin, might allow remote authenticated users to obtain sensitive information from…
5.3
CVE-2024-34768
WordPress Fastly plugin <= 1.2.25 - Broken Access Control vulnerability
4.3
CVE-2025-58199
WordPress Fastly plugin <= 1.2.28 - Cross Site Request Forgery (CSRF) vulnerability
4.3
CVE-2024-34803
WordPress Fastly plugin <= 1.2.25 - Broken Access Control vulnerability
